Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
P
pidptools
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
PETRA III Debian Packages
pidptools
Commits
f6609555
Commit
f6609555
authored
8 years ago
by
Jan Kotanski
Browse files
Options
Downloads
Patches
Plain Diff
New upstream version 1.4.0
parent
c88ef19b
No related branches found
No related tags found
No related merge requests found
Changes
6
Hide whitespace changes
Inline
Side-by-side
Showing
6 changed files
PKG-INFO
+1
-1
1 addition, 1 deletion
PKG-INFO
pidpbuild
+32
-3
32 additions, 3 deletions
pidpbuild
pidpclone
+5
-5
5 additions, 5 deletions
pidpclone
pidpcreate
+1
-1
1 addition, 1 deletion
pidpcreate
pidppush
+1
-1
1 addition, 1 deletion
pidppush
setup.py
+1
-1
1 addition, 1 deletion
setup.py
with
41 additions
and
12 deletions
PKG-INFO
+
1
−
1
View file @
f6609555
Metadata-Version: 1.0
Name: pidp.tools
Version: 1.
3.4
Version: 1.
4.0
Summary: PETRA III Debian Package Tools
Home-page: https://stash.desy.de/projects/JMK/repos/pidptools/browse/
Author: Jan Kotanski
...
...
This diff is collapsed.
Click to expand it.
pidpbuild
+
32
−
3
View file @
f6609555
...
...
@@ -45,6 +45,15 @@ do
-p
|
--patch
)
export
PATCH
=
YES
;;
-pb
|
--pbuilder
)
export
PBUILDER
=
YES
;;
-cpb
|
--createpb
)
export
CREATEPB
=
YES
;;
-a
=
*
|
--arch
=
*
)
export
ARCH
=
"
${
i
#*=
}
"
;;
-c
|
--continue
)
export
CONTINUE
=
YES
;;
...
...
@@ -66,7 +75,7 @@ if [[ ! -z $HELP ]] && [[ -z $PACKAGE ]] ; then
echo
"Error: PACKAGE variable is not defined"
fi
if
[[
!
-z
$HELP
]]
||
[[
-z
$PACKAGE
]]
;
then
echo
"pidpbuild version 1.
3.4
"
echo
"pidpbuild version 1.
4.0
"
echo
""
echo
"usage: pidpbuild [<TARBALL>] [-v=<VERSION>] [-ns|--no-signature]"
echo
" [-e=<DEBEMAIL>] [-f=<DEBFULLNAME>] [-ne|--nodebenv]"
...
...
@@ -92,6 +101,9 @@ if [[ ! -z $HELP ]] || [[ -z $PACKAGE ]] ; then
echo
" -m, --merge upstream/* merged into debian/*"
echo
" by default: replace is performed"
echo
" -p, --patch the patching procedure"
echo
" -pb, --pbuilder use git-pbuilder"
echo
" --cpb, --createpb create git-pbuilder environment"
echo
" -a=, --arch= git-pbuilder architecture"
echo
" -c, --continue continue the built of the debian package, e.g.:"
echo
" after a conflict detected between patches "
echo
" and the new source tarball or "
...
...
@@ -131,6 +143,12 @@ else
echo
" DEBFULLNAME=
\"
$DEBFULLNAME
\"
"
echo
" DEBEMAIL=
\"
$DEBEMAIL
\"
"
echo
""
if
!
[[
-z
$PBUILDER
]]
;
then
if
[[
-z
$CREATEPB
]]
;
then
DIST
=
$RELEASE
git-pbuilder update
else
DIST
=
$RELEASE
git-pbuilder create
fi
if
[[
-z
$VERSION
]]
;
then
RE
=
'^[0-9]+$'
read
-r
FIRSTLINE < debian/changelog
...
...
@@ -260,9 +278,20 @@ else
fi
git clean
-f
-d
if
[[
-z
$NOSIGNATURE
]]
;
then
gbp buildpackage
--git-tag
if
[[
-z
$PBUILDER
]]
;
then
gbp buildpackage
--git-tag
else
gbp buildpackage
--git-tag
--git-pbuilder
--git-dist
=
$RELEASE
lintian
debsign
fi
else
gbp buildpackage
-us
-uc
--git-tag
if
[[
-z
$PBUILDER
]]
;
then
gbp buildpackage
-us
-uc
--git-tag
else
gbp buildpackage
--git-tag
--git-pbuilder
--git-dist
=
$RELEASE
lintian
fi
fi
if
[[
!
-z
$PIDTOKILL
]]
;
then
(
sleep
1
&&
kill
-TERM
$PPID
$PIDTOKILL
&
)
...
...
This diff is collapsed.
Click to expand it.
pidpclone
+
5
−
5
View file @
f6609555
...
...
@@ -59,7 +59,7 @@ if [[ ! -z $HELP ]] && [[ -z $PACKAGE ]] ; then
echo
"Error: PACKAGE variable is not defined"
fi
if
[[
!
-z
$HELP
]]
||
[[
-z
$PACKAGE
]]
;
then
echo
"pidpclone version 1.
3.4
"
echo
"pidpclone version 1.
4.0
"
echo
""
echo
"usage: pidpclone <DEB-PACKAGE-NAME> [-p|--patch] [-u=<USER>] [-h|--help]"
echo
" [-e=<DEBEMAIL>] [-f=<DEBFULLNAME>] [-ne|--nodebenv] "
...
...
@@ -120,17 +120,17 @@ else
git fetch
--all
if
[[
$(
git checkout
-b
upstream/
$RELEASE
origin/upstream/
$RELEASE
>
/dev/null 2>&1
)
&&
$?
]]
;
then
git checkout upstream/
$RELEASE
git pull origin upstream/
$RELEASE
||
true
git pull origin upstream/
$RELEASE
fi
if
[[
$(
git checkout
-b
pristine-tar origin/pristine-tar
>
/dev/null 2>&1
)
&&
$?
]]
;
then
git checkout pristine-tar
git pull origin pristine-tar
||
true
git pull origin pristine-tar
fi
if
[[
$(
git checkout
-b
debian/
$RELEASE
origin/debian/
$RELEASE
>
/dev/null 2>&1
)
&&
$?
]]
;
then
git pull origin debian/
$RELEASE
||
true
git pull origin debian/
$RELEASE
else
git checkout debian/
$RELEASE
git pull origin debian/
$RELEASE
||
true
git pull origin debian/
$RELEASE
fi
git clean
-f
-d
git commit
-a
-m
'clean the repository'
>
/dev/null 2>&1
||
true
...
...
This diff is collapsed.
Click to expand it.
pidpcreate
+
1
−
1
View file @
f6609555
...
...
@@ -70,7 +70,7 @@ if [[ ! -z $HELP ]] && [[ -z $TARBALL ]] ; then
echo
"Error: TARBALL variable is not defined"
fi
if
[[
!
-z
$HELP
]]
||
[[
-z
$PACKAGE
]]
||
[[
-z
$TARBALL
]]
;
then
echo
"pidpbuild version 1.
3.4
"
echo
"pidpbuild version 1.
4.0
"
echo
""
echo
"usage: pidpcreate <DEB-PACKAGE-NAME> <TARBALL> [-v=<SRCVERSION>] [-ns|--no-signature]"
echo
" [-e=<DEBEMAIL>] [-f=<DEBFULLNAME>] [-ne|--nodebenv]"
...
...
This diff is collapsed.
Click to expand it.
pidppush
+
1
−
1
View file @
f6609555
...
...
@@ -45,7 +45,7 @@ if [[ ! -z $HELP ]] && [[ -z $DEBPACKAGE ]] ; then
echo
"Error: DEB-PACKAGE-NAME argument is not defined"
fi
if
[[
!
-z
$HELP
]]
||
[[
-z
$DEBPACKAGE
]]
;
then
echo
"pidppush version 1.
3.4
"
echo
"pidppush version 1.
4.0
"
echo
""
echo
"usage: pidppush <DEB-PACKAGE-NAME> "
echo
""
...
...
This diff is collapsed.
Click to expand it.
setup.py
+
1
−
1
View file @
f6609555
...
...
@@ -30,7 +30,7 @@ def read(fname):
return
open
(
os
.
path
.
join
(
os
.
path
.
dirname
(
__file__
),
fname
)).
read
()
#: (:obj:`str`) full release number
release
=
'
1.
3.4
'
release
=
'
1.
4.0
'
#: (:obj:`dict` <:obj:`str` , any >`) metadata for distutils
SETUPDATA
=
dict
(
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment