Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
P
pidptools
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
PETRA III Debian Packages
pidptools
Commits
b9fd0138
Commit
b9fd0138
authored
7 years ago
by
Jan Kotanski
Browse files
Options
Downloads
Patches
Plain Diff
New upstream version 1.6.1
parent
0017a27f
No related branches found
Branches containing commit
Tags
upstream/jessie/1.6.1
Tags containing commit
No related merge requests found
Changes
6
Hide whitespace changes
Inline
Side-by-side
Showing
6 changed files
PKG-INFO
+1
-1
1 addition, 1 deletion
PKG-INFO
pidpbuild
+50
-50
50 additions, 50 deletions
pidpbuild
pidpclone
+1
-1
1 addition, 1 deletion
pidpclone
pidpcreate
+1
-1
1 addition, 1 deletion
pidpcreate
pidppush
+1
-1
1 addition, 1 deletion
pidppush
setup.py
+1
-1
1 addition, 1 deletion
setup.py
with
55 additions
and
55 deletions
PKG-INFO
+
1
−
1
View file @
b9fd0138
Metadata-Version: 1.0
Name: pidp.tools
Version: 1.6.
0
Version: 1.6.
1
Summary: PETRA III Debian Package Tools
Home-page: https://stash.desy.de/projects/JMK/repos/pidptools/browse/
Author: Jan Kotanski
...
...
This diff is collapsed.
Click to expand it.
pidpbuild
+
50
−
50
View file @
b9fd0138
...
...
@@ -17,7 +17,7 @@
# along with nexdatas. If not, see <http://www.gnu.org/licenses/>.
#
set
-e
PIDPVERSION
=
"1.6.
0
"
PIDPVERSION
=
"1.6.
1
"
for
i
in
"
${
@
:1
}
"
do
if
[[
$i
==
-
*
]]
;
then
...
...
@@ -141,64 +141,64 @@ else
MYOTHERMIRROR
=
$MYOTHERMIRROR
" | deb http://repos.pni-hdri.de/apt/debian
$TRRELEASE
main"
fi
fi
if
[
-z
$CONTINUE
]
;
then
CDIR
=
${
PWD
##*/
}
if
!
[[
"
$CDIR
"
==
"
$PACKAGE
"
]]
;
then
cd
$PACKAGE
fi
git clean
-f
-d
if
[
-z
$NODEBENV
]
;
then
if
[[
-z
$DEBEMAIL
]]
;
then
export
DEBEMAIL
=
"fsec-devel@desy.de"
fi
if
[[
-z
$DEBFULLNAME
]]
;
then
export
DEBFULLNAME
=
"FS-EC DESY Group"
fi
fi
if
[[
!
-z
$FULLNAME
]]
;
then
export
DEBFULLNAME
=
$FULLNAME
fi
if
[[
!
-z
$EMAIL
]]
;
then
export
DEBEMAIL
=
$EMAIL
CDIR
=
${
PWD
##*/
}
if
!
[[
"
$CDIR
"
==
"
$PACKAGE
"
]]
;
then
cd
$PACKAGE
fi
git clean
-f
-d
if
[
-z
$NODEBENV
]
;
then
if
[[
-z
$DEBEMAIL
]]
;
then
export
DEBEMAIL
=
"fsec-devel@desy.de"
fi
if
[[
-z
$
RELEAS
E
]]
;
then
export
RELEASE
=
$DEFRELEASE
if
[[
-z
$
DEBFULLNAM
E
]]
;
then
export
DEBFULLNAME
=
"FS-EC DESY Group"
fi
echo
""
echo
" DEBFULLNAME=
\"
$DEBFULLNAME
\"
"
echo
" DEBEMAIL=
\"
$DEBEMAIL
\"
"
echo
""
if
!
[[
-z
$PBUILDER
]]
;
then
if
[[
-z
$MYOTHERMIRROR
]]
;
then
if
[[
-z
$CREATEPB
]]
;
then
if
[[
-z
$ARCH
]]
;
then
DIST
=
$RELEASE
git-pbuilder update
else
ARCH
=
$ARCH
DIST
=
$RELEASE
git-pbuilder update
fi
fi
if
[[
!
-z
$FULLNAME
]]
;
then
export
DEBFULLNAME
=
$FULLNAME
fi
if
[[
!
-z
$EMAIL
]]
;
then
export
DEBEMAIL
=
$EMAIL
fi
if
[[
-z
$RELEASE
]]
;
then
export
RELEASE
=
$DEFRELEASE
fi
echo
""
echo
" DEBFULLNAME=
\"
$DEBFULLNAME
\"
"
echo
" DEBEMAIL=
\"
$DEBEMAIL
\"
"
echo
""
if
!
[[
-z
$PBUILDER
]]
;
then
if
[[
-z
$MYOTHERMIRROR
]]
;
then
if
[[
-z
$CREATEPB
]]
;
then
if
[[
-z
$ARCH
]]
;
then
DIST
=
$RELEASE
git-pbuilder update
else
if
[[
-z
$ARCH
]]
;
then
DIST
=
$RELEASE
git-pbuilder create
else
ARCH
=
$ARCH
DIST
=
$RELEASE
git-pbuilder create
fi
ARCH
=
$ARCH
DIST
=
$RELEASE
git-pbuilder update
fi
else
if
[[
-z
$CREATEPB
]]
;
then
if
[[
-z
$ARCH
]]
;
then
DIST
=
$RELEASE
git-pbuilder update
--othermirror
=
"
$MYOTHERMIRROR
"
else
ARCH
=
$ARCH
DIST
=
$RELEASE
git-pbuilder update
--othermirror
=
"
$MYOTHERMIRROR
"
fi
if
[[
-z
$ARCH
]]
;
then
DIST
=
$RELEASE
git-pbuilder create
else
if
[[
-z
$ARCH
]]
;
then
DIST
=
$RELEASE
git-pbuilder create
--othermirror
=
"
$MYOTHERMIRROR
"
else
ARCH
=
$ARCH
DIST
=
$RELEASE
git-pbuilder create
--othermirror
=
"
$MYOTHERMIRROR
"
fi
ARCH
=
$ARCH
DIST
=
$RELEASE
git-pbuilder create
fi
fi
else
if
[[
-z
$CREATEPB
]]
;
then
if
[[
-z
$ARCH
]]
;
then
DIST
=
$RELEASE
git-pbuilder update
--othermirror
=
"
$MYOTHERMIRROR
"
else
ARCH
=
$ARCH
DIST
=
$RELEASE
git-pbuilder update
--othermirror
=
"
$MYOTHERMIRROR
"
fi
else
if
[[
-z
$ARCH
]]
;
then
DIST
=
$RELEASE
git-pbuilder create
--othermirror
=
"
$MYOTHERMIRROR
"
else
ARCH
=
$ARCH
DIST
=
$RELEASE
git-pbuilder create
--othermirror
=
"
$MYOTHERMIRROR
"
fi
fi
fi
fi
if
[
-z
$CONTINUE
]
;
then
if
[[
-z
$VERSION
]]
;
then
RE
=
'^[0-9]+$'
read
-r
FIRSTLINE < debian/changelog
...
...
This diff is collapsed.
Click to expand it.
pidpclone
+
1
−
1
View file @
b9fd0138
...
...
@@ -16,7 +16,7 @@
# You should have received a copy of the GNU General Public License
# along with nexdatas. If not, see <http://www.gnu.org/licenses/>.
#
PIDPVERSION
=
"1.6.
0
"
PIDPVERSION
=
"1.6.
1
"
for
i
in
"
${
@
:1
}
"
do
if
[[
$i
==
-
*
]]
;
then
...
...
This diff is collapsed.
Click to expand it.
pidpcreate
+
1
−
1
View file @
b9fd0138
...
...
@@ -17,7 +17,7 @@
# along with nexdatas. If not, see <http://www.gnu.org/licenses/>.
#
set
-e
PIDPVERSION
=
"1.6.
0
"
PIDPVERSION
=
"1.6.
1
"
for
i
in
"
${
@
:1
}
"
do
if
[[
$i
==
-
*
]]
;
then
...
...
This diff is collapsed.
Click to expand it.
pidppush
+
1
−
1
View file @
b9fd0138
...
...
@@ -17,7 +17,7 @@
# along with nexdatas. If not, see <http://www.gnu.org/licenses/>.
#
PIDPVERSION
=
"1.6.
0
"
PIDPVERSION
=
"1.6.
1
"
for
i
in
"
${
@
:1
}
"
do
if
[[
$i
==
-
*
]]
;
then
...
...
This diff is collapsed.
Click to expand it.
setup.py
+
1
−
1
View file @
b9fd0138
...
...
@@ -30,7 +30,7 @@ def read(fname):
return
open
(
os
.
path
.
join
(
os
.
path
.
dirname
(
__file__
),
fname
)).
read
()
#: (:obj:`str`) full release number
release
=
"
1.6.
0
"
release
=
"
1.6.
1
"
#: (:obj:`dict` <:obj:`str` , any >`) metadata for distutils
SETUPDATA
=
dict
(
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment