Skip to content
Snippets Groups Projects
Unverified Commit d638a78e authored by Jan Kotanski's avatar Jan Kotanski
Browse files

add jpeg bzip2 and blosc

parent febf943d
No related branches found
No related tags found
No related merge requests found
......@@ -6,6 +6,8 @@ Build-Depends: debhelper (>= 9),
libhdf5-dev (>=1.8.11),
liblz4-dev,
libbz2-dev,
libblosc-dev,
libjpeg-dev,
hdf5-tools (>=1.8.11)
Standards-Version: 4.1.3
Section: science
......@@ -14,7 +16,7 @@ Homepage: https://github.com/michaelrissi/HDF5Plugin
Package: hdf5-plugin-lz4
Section: science
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends},hdf5-plugins-common
Depends: ${shlibs:Depends}, ${misc:Depends}
Pre-Depends: ${misc:Pre-Depends}
Description: HDF5 plugin - LZ4 compression
LZ4 compression filter for the HDF5 library.
......@@ -22,16 +24,33 @@ Description: HDF5 plugin - LZ4 compression
Package: hdf5-plugin-bshuf
Section: science
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends},hdf5-plugins-common
Depends: ${shlibs:Depends}, ${misc:Depends}
Pre-Depends: ${misc:Pre-Depends}
Description: HDF5 plugin - Bit Shuffle compression
BShuf compression filter for the HDF5 library.
# Package: hdf5-plugin-bz2
# Section: science
# Architecture: any
# Depends: ${shlibs:Depends}, ${misc:Depends},hdf5-plugins-common
# Pre-Depends: ${misc:Pre-Depends}
# Description: HDF5 plugin - BZIP2 compression
# BZ2 compression filter for the HDF5 library.
Package: hdf5-plugin-bz2
Section: science
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Pre-Depends: ${misc:Pre-Depends}
Description: HDF5 plugin - BZIP2 compression
BZ2 compression filter for the HDF5 library.
Package: hdf5-plugin-blosc
Section: science
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Pre-Depends: ${misc:Pre-Depends}
Description: HDF5 plugin - BLOSC compression
BLOSC compression filter for the HDF5 library.
Package: hdf5-plugin-jpeg
Section: science
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Pre-Depends: ${misc:Pre-Depends}
Description: HDF5 plugin - JPEG compression
JPEG compression filter for the HDF5 library.
/usr/lib/*/hdf5/plugins/libh5blosc.so
\ No newline at end of file
/usr/lib/*/hdf5/plugins/libh5jpeg.so
\ No newline at end of file
From: Jan Kotanski <jankotan@gmail.com>
Date: Thu, 13 Feb 2020 09:11:09 +0100
Subject: cmake bzip2 configuration
---
BZIP2/CMakeLists.txt | 12 ++++++------
BZIP2/src/CMakeLists.txt | 2 +-
2 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/BZIP2/CMakeLists.txt b/BZIP2/CMakeLists.txt
index d680e3c..4cf57d8 100644
--- a/BZIP2/CMakeLists.txt
+++ b/BZIP2/CMakeLists.txt
@@ -80,15 +80,15 @@ if (NOT BZ2_USE_EXTERNAL)
find_package (BZ2 NAMES ${BZ2_PACKAGE_NAME} COMPONENTS ${FIND_BZ2_COMPONENTS})
message (STATUS "BZ2 C libs: static:${BZ2_static_FOUND}")
if (NOT BZ2_FOUND)
- find_package (BZ2) # Legacy find
+ find_package (BZip2) # Legacy find
endif ()
endif ()
-if (BZ2_FOUND)
+if (BZIP2_FOUND)
set (H5BZ2_HAVE_BZLIB_H 1)
set (H5BZ2_HAVE_BZ2 1)
set (H5BZ2_BZ2_HEADER "bzlib.h")
- set (BZ2_INCLUDE_DIR_GEN ${BZ2_INCLUDE_DIR})
- set (BZ2_INCLUDE_DIRS ${BZ2_INCLUDE_DIR})
+ set (BZ2_INCLUDE_DIR_GEN ${BZIP2_INCLUDE_DIR})
+ set (BZ2_INCLUDE_DIRS ${BZIP2_INCLUDE_DIR})
else ()
if (H5PL_ALLOW_EXTERNAL_SUPPORT MATCHES "GIT" OR H5PL_ALLOW_EXTERNAL_SUPPORT MATCHES "TGZ")
EXTERNAL_BZ2_LIBRARY (${H5PL_ALLOW_EXTERNAL_SUPPORT} STATIC)
@@ -99,8 +99,8 @@ else ()
message (FATAL_ERROR " bz2 is Required for ${H5BZ2_PACKAGE_NAME} library")
endif ()
endif ()
-message (STATUS "bz2 found: INC=${BZ2_INCLUDE_DIR} LIBS=${BZ2_LIBRARIES}")
-set (LINK_LIBS ${LINK_LIBS} ${BZ2_LIBRARIES})
+message (STATUS "bz2 found: INC=${BZIP2_INCLUDE_DIR} LIBS=${BZIP2_LIBRARIES}")
+set (LINK_LIBS ${LINK_LIBS} ${BZIP2_LIBRARIES})
#-----------------------------------------------------------------------------
# Dashboard and Testing Settings
diff --git a/BZIP2/src/CMakeLists.txt b/BZIP2/src/CMakeLists.txt
index 30b132c..b36a59e 100644
--- a/BZIP2/src/CMakeLists.txt
+++ b/BZIP2/src/CMakeLists.txt
@@ -12,7 +12,7 @@ add_definitions (${HDF5_EXTRA_C_FLAGS})
set(H5BZ2_INCLUDE_DIRS ${H5BZ2_INCLUDE_DIRS}
${HDF5_INCLUDE_DIR} ${H5BZ2_BINARY_DIR}
${H5BZ2_SRC_SOURCE_DIR}
- ${BZ2_INCLUDE_DIRS}
+ ${BZIP2_INCLUDE_DIRS}
)
#-----------------------------------------------------------------------------
From: Jan Kotanski <jankotan@gmail.com>
Date: Thu, 13 Feb 2020 09:13:32 +0100
Subject: cmake blosc configuration
---
BLOSC/CMakeLists.txt | 2 +-
config/cmake/FindBlosc.cmake | 8 ++++++++
2 files changed, 9 insertions(+), 1 deletion(-)
create mode 100644 config/cmake/FindBlosc.cmake
diff --git a/BLOSC/CMakeLists.txt b/BLOSC/CMakeLists.txt
index 5f231c0..67e3a27 100644
--- a/BLOSC/CMakeLists.txt
+++ b/BLOSC/CMakeLists.txt
@@ -156,7 +156,7 @@ if (HDF_ENABLE_BLOSC_SUPPORT)
if (NOT BLOSC_USE_EXTERNAL)
find_package (BLOSC NAMES ${BLOSC_PACKAGE_NAME}${HDF_PACKAGE_EXT} COMPONENTS static)
if (NOT BLOSC_FOUND)
- find_package (BLOSC) # Legacy find
+ find_package (Blosc) # Legacy find
if (BLOSC_FOUND)
set (LINK_LIBS ${LINK_LIBS} ${BLOSC_LIBRARIES})
endif ()
diff --git a/config/cmake/FindBlosc.cmake b/config/cmake/FindBlosc.cmake
new file mode 100644
index 0000000..122f1ef
--- /dev/null
+++ b/config/cmake/FindBlosc.cmake
@@ -0,0 +1,8 @@
+find_path(BLOSC_INCLUDE_DIR blosc.h)
+
+find_library(BLOSC_LIBRARY NAMES blosc)
+
+if (BLOSC_INCLUDE_DIR AND BLOSC_LIBRARY)
+ set(BLOSC_FOUND TRUE)
+endif ()
+
0001-comment-a-debugging-printout.patch
0002-cmake-bzip2-configuration.patch
0003-cmake-blosc-configuration.patch
......@@ -14,7 +14,7 @@ GNUARCH:=$(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
override_dh_auto_configure:
# dh_auto_configure -- -DENABLE_LZ4_PLUGIN=ON -DENABLE_BZIP2_PLUGIN=ON -DENABLE_BITSHUFFLE_PLUGIN=ON -DCMAKE_INSTALL_LIBDIR=$(DEST)/usr/lib/$(GNUARCH)/hdf5
dh_auto_configure -- -DH5PL_SOURCE_DIR="$(CURDIR)" -DH5PL_RESOURCES_DIR="$(CURDIR)/config/cmake" -DPL_PACKAGE_NAME="pl" -DBSHUF_PACKAGE_NAME="bshuf" -DLZ4_PACKAGE_NAME="lz4" -DBZ2_PACKAGE_NAME="bz2" -DENABLE_BSHUF=ON -DENABLE_BLOSC=OFF -DENABLE_BZIP2=OFF -DENABLE_JPEG=OFF -DENABLE_LZF=OFF -DENABLE_LZ4=ON -DENABLE_MAFISC=OFF -DENABLE_ZFP=OFF -DHDF5_PACKAGE_NAME=hdf5 -DCMAKE_INSTALL_LIBDIR=$(DEST)/usr/lib/$(GNUARCH)/hdf5
dh_auto_configure -- -DH5PL_SOURCE_DIR="$(CURDIR)" -DH5PL_RESOURCES_DIR="$(CURDIR)/config/cmake" -DPL_PACKAGE_NAME="pl" -DBSHUF_PACKAGE_NAME="bshuf" -DLZ4_PACKAGE_NAME="lz4" -DBZ2_PACKAGE_NAME="bz2" -DENABLE_BSHUF=ON -DENABLE_BLOSC=ON -DENABLE_BZIP2=ON -DENABLE_JPEG=ON -DENABLE_LZF=OFF -DENABLE_LZ4=ON -DENABLE_MAFISC=OFF -DENABLE_ZFP=OFF -DBLOSC_PACKAGE_NAME="blosc" -DBZ2_PACKAGE_NAME="BZ2" -DLZ4_PACKAGE_NAME="LZ4" -DJPEG_PACKAGE_NAME="JPEG" -DHDF5_PACKAGE_NAME=hdf5 -DCMAKE_INSTALL_LIBDIR=$(DEST)/usr/lib/$(GNUARCH)/hdf5
override_dh_auto_install:
dh_auto_install
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment