From 5416af5b0ee79b877fc90b5eaaf4f176e1f34b28 Mon Sep 17 00:00:00 2001
From: jkotan <jankotan@gmail.com>
Date: Mon, 25 Oct 2021 17:48:05 +0200
Subject: [PATCH] remove python2

---
 debian/compat  |  2 +-
 debian/control | 18 ++----------------
 debian/rules   |  5 +----
 3 files changed, 4 insertions(+), 21 deletions(-)

diff --git a/debian/compat b/debian/compat
index ec63514..f599e28 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/debian/control b/debian/control
index a6839f9..3ebe399 100644
--- a/debian/control
+++ b/debian/control
@@ -2,22 +2,10 @@ Source: python-punx
 Section: python
 Priority: optional
 Maintainer: Jan Kotanski (jkotan) <jankotan@gmail.com>
-Build-Depends: python (>=2.6), debhelper (>=9.0), python-all, dh-python, python-setuptools, python-numpy, python3-all, dh-python, python3-setuptools, python3-numpy, python3-six, python-six, python-h5py, python3-h5py, python-github, python3-github
+Build-Depends: python3 (>=3.3), debhelper (>=10.0), python3-all, dh-python, python3-setuptools, python3-numpy, python3-six, python3-h5py, python3-github
 Vcs-browser: https://github.com/nexpy/punx/
 Homepage: https://github.com/nexpy/punx/
-X-Python-Version: >=2.7
-X-Python3-Version: >= 3.2
-Standards-Version: 3.9.8
-
-Package: python-punx
-Architecture: all
-Homepage: https://github.com/nexpy/punx/
-Depends: ${python:Depends}, ${misc:Depends}, python-h5py (>=2.2.1), python-tz, python-numpy, python-h5py (>=2.2.1), python-six, python-qt4, python-requests, python-lxml, python-github, python-pyresttable
-Provides: ${python:Provides}
-Description: Python Utilities for NeXus HDF5 files
- .
- Look for more information about this:
- https://github.com/nexpy/punx/
+Standards-Version: 4.3.0
 
 Package: punx
 Architecture: all
@@ -25,7 +13,6 @@ Homepage: https://github.com/nexpy/punx/
 Provides: ${python3:Provides}
 Depends: python3-punx, ${python3:Depends}, ${misc:Depends}, python3-h5py (>=2.2.1), python3-tz, python3-numpy, python3-h5py (>=2.2.1), python3-six, python3-pyqt4, python3-requests, python3-lxml, python3-github, python3-pyresttable
 Description: Python Utilities for NeXus HDF5 files
- .
  Look for more information about this:
  https://github.com/nexpy/punx/
 
@@ -35,6 +22,5 @@ Homepage: https://github.com/nexpy/punx/
 Provides: ${python3:Provides}
 Depends: ${python3:Depends}, ${misc:Depends}, python3-h5py (>=2.2.1), python3-tz, python3-numpy, python3-h5py (>=2.2.1), python3-six, python3-pyqt4, python3-requests, python3-lxml, python3-github, python3-pyresttable
 Description: Python Utilities for NeXus HDF5 files
- .
  Look for more information about this:
  https://github.com/nexpy/punx/
diff --git a/debian/rules b/debian/rules
index f7e2921..f4cb573 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,22 +3,19 @@
 export DH_VERBOSE=1
 export PYBUILD_NAME=punx
 
-PYTHON2_VERSIONS = $(shell pyversions -r)
 PYTHON3_VERSIONS = $(shell py3versions -r)
 
 %:
-	dh $@ --with python2,python3  --buildsystem=pybuild
+	dh $@ --with python3  --buildsystem=pybuild
 
 override_dh_auto_clean:
 	dh_auto_clean
 	rm -rf build
 
 override_dh_auto_install:
-	dh_numpy
 	dh_numpy3
 	dh_auto_install
 
-	rm -rf debian/python-punx/usr/bin
 	mkdir -p debian/punx/usr
 	mv $(CURDIR)/debian/python3-punx/usr/bin $(CURDIR)/debian/punx/usr
 
-- 
GitLab