#!/usr/bin/make -f
# See debhelper(7) (uncomment to enable)
# output every command that modifies files on the build system.
# export DH_VERBOSE=1

CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
CFLAGS:=$(shell dpkg-buildflags --get CFLAGS) $(CPPFLAGS)
CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS) $(CPPFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
GNUARCH:=$(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)

%:
	dh $@  --buildsystem=cmake

override_dh_auto_configure:
	dh_auto_configure -- -DENABLE_LZ4_PLUGIN=ON -DENABLE_BZIP2_PLUGIN=ON -DENABLE_BITSHUFFLE_PLUGIN=ON -DCMAKE_INSTALL_LIBDIR=$(DEST)/usr/lib/$(GNUARCH)/hdf5