#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
CFLAGS:=$(shell dpkg-buildflags --get CFLAGS) $(CPPFLAGS)
CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS) $(CPPFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
GNUARCH:=$(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)

%:
	dh $@  --buildsystem=cmake

# .PHONY: override_dh_strip

override_dh_auto_configure:
	dh_auto_configure -- -DENABLE_LZ4_PLUGIN=ON -DENABLE_BZIP2_PLUGIN=ON -DENABLE_BITSHUFFLE_PLUGIN=ON -DCMAKE_INSTALL_LIBDIR=$(DEST)/usr/lib/$(GNUARCH)/hdf5


# override_dh_auto_build:
#	cd $(BUILDDIR) && make html
#	dh_auto_build --parallel

# override_dh_install:
#	@echo nothing to do for dh_install

override_dh_installdocs:
	dh_installdocs

#override_dh_auto_configure:
#	dh_auto_configure -- --disable-static --libdir=$(DEST)/usr/lib/$(GNUARCH)/hdf5/plugins

#override_dh_auto_test:
#        #do nothing here


# override_dh_install:
#	dh_install

# override_dh_auto_test:
#	cd $(BUILDDIR) && make test	# cd $(BUILDDIR) && make check -j4

#override_dh_strip:
#	dh_strip --dbg-package=hdf5-plugin-lz4-dbg