Commit f7f0e2b8 authored by Nadeem Shehzad's avatar Nadeem Shehzad
Browse files

added zmq dependency. Increased patch number for release.

parent 846d864d
PROJECT(gpsdo)
PROJECT(gpsdo_server)
cmake_minimum_required(VERSION 2.8)
list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/Modules)
set(${PROJECT_NAME}_MAJOR_VERSION 01)
set(${PROJECT_NAME}_MINOR_VERSION 01)
set(${PROJECT_NAME}_PATCH_VERSION 00)
set(${PROJECT_NAME}_PATCH_VERSION 01)
include(cmake/set_version_numbers.cmake)
# Moderate version of the compiler flags
......@@ -21,8 +21,7 @@ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -O0 --coverage")
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--export-dynamic")
include(cmake/add_dependency.cmake)
#add_dependency(DOOCS 18.10.9 COMPONENTS server REQUIRED)
add_dependency(DOOCS 18.10.15 server REQUIRED)
add_dependency(DOOCS 18.10.9 COMPONENTS server zmq REQUIRED)
#add_dependency(doocs-server-test-helper 0.3 REQUIRED) maybe needed later
add_dependency(Doocs-RF-Util 0.1 REQUIRED)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment