Commit f7866655 authored by olaf michaelis's avatar olaf michaelis
Browse files

Fix python version conflict that occured because of the latest debian pulling a python 3.7 version

parent 1af007ec
FROM httpd:latest
FROM debian:latest
ARG UID=<UID>
ENV USER="rdmo"
ENV HTTPD_CONF="/usr/local/apache2/conf/httpd.conf"
ENV HTTPD_VHOSTS="/usr/local/apache2/conf.d/vhosts.conf"
ENV APACHE_RUN_DIR=/var/run/apache2
ENV APACHE_PID_FILE=/var/run/apache2/apache2.pid
ENV APACHE_RUN_USER="rdmo"
ENV APACHE_RUN_GROUP="rdmo"
ENV APACHE_LOG_DIR=/vol/log
RUN apt update -y && apt install -y \
apache2 \
curl \
python-psycopg2 \
libexpat1 \
......@@ -18,16 +23,17 @@ RUN apt update -y && apt install -y \
pandoc \
texlive-xetex
RUN echo "LoadModule wsgi_module /usr/lib/apache2/modules/mod_wsgi.so" >> ${HTTPD_CONF} \
&& echo "IncludeOptional conf.d/*.conf" >> ${HTTPD_CONF}
RUN echo "LoadModule wsgi_module /etc/apache2/modules/mod_wsgi.so" \
>> "/etc/apache2/apache2.conf"
RUN mkdir -p /usr/local/apache2/conf.d
COPY ./vhosts.conf "${HTTPD_VHOSTS}"
RUN rm -f /etc/apache2/sites-enabled/*
COPY ./vhosts.conf "/etc/apache2/sites-enabled/vhosts.conf"
COPY ./drun.sh /drun.sh
COPY ./healthcheck.sh /healthcheck.sh
RUN useradd -m -u ${UID} -s /bin/bash rdmo
RUN useradd -m -u "${UID}" "${USER}"
RUN mkdir -p /var/www/html
RUN mkdir -p /var/run/apache2
......
......@@ -16,5 +16,6 @@ export BASE_STATIC=$(sanitize "${BASE_URL}/static")
export BASE_URL=$(sanitize "${BASE_URL}")
# apache gets grumpy about pre-existing pid files
rm -f /usr/local/apache2/logs/httpd.pid
httpd -DFOREGROUND
rm -f /var/run/apache2/apache2.pid
apache2 -DFOREGROUND
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment