Commit b68e6af0 authored by Jerome Carnis's avatar Jerome Carnis 🦊
Browse files

Drop support for Python3.7, not compatible anymore with the latest pint

parent 451ce952
Pipeline #27664 passed with stages
in 9 minutes and 33 seconds
......@@ -66,15 +66,6 @@ unit-tests:
- python -m pip install -r requirements.txt
- PYTHONPATH=".:$PYTHONPATH" pytest
unit-tests-37:
image: python:3.7
stage: test
script:
- python -m pip install --upgrade pip
- python -m pip install pytest pytest-cov pytest-lazy-fixture pytest-mock
- python -m pip install -r requirements.txt
- PYTHONPATH=".:$PYTHONPATH" pytest
unit-tests-38:
image: python:3.8
stage: test
......
......@@ -21,7 +21,7 @@ The documentation is available at: https://cfel-sc-public.pages.desy.de/kamzik3/
Requirements
============
* Python: 3.7 and higher
* Python: 3.8 or 3.9
**Python Modules: Backend**
......
......@@ -15,8 +15,10 @@ setuptools.setup(
packages=setuptools.find_packages(),
package_data={"kamzik3": ["*.yml"], "kamzik3.example": ["*.yml", "*.att"]},
classifiers=[
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Operating System :: OS Independent",
"Development Status :: 3 - Alpha",
"Topic :: Software Development :: Libraries :: Python Modules",
"License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)",
"Natural Language :: English",
......@@ -52,5 +54,5 @@ setuptools.setup(
"pytest-lazy-fixture": [],
"pytest-mock": [],
},
python_requires=">=3.7",
python_requires=">=3.8, <3.10",
)
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment